您的浏览器不支持CSS3,建议使用Firfox、Chrome等浏览器,以取得最佳显示效果

IE8不支持jQuery问题

Web相关 1,016℃ 0 3年前 (2015-03-18)

最近做WordPress主题,遇到一个很奇怪的问题,网页在Chrome等浏览器都显示正常,但是到了IE8里面就无法工作。提示“加载完毕,但网页中有错误”。

尝试修复IE浏览器,但是毫无效果。后来经过反复排查,发现问题在于IE8不能运行jQuery。网上找了很久也没找到相关的文章。而且之前用过一些jQuery插件,在IE中也是能正常使用的。用IE打开之前写的一个jQuery插件的Demo,运行正常,又在想是不是CDN的原因,于是把CDN引用的jQuery换成本地的jQuery文件,还是没有效果。。。

猜测可能是IE8对CDN的支持有问题,用“ie8 jquery cdn”作为关键字搜索,结果意外找到了答案,原来是因为CDN我引用的是2.1版本的jQuery,而2.0以上版本的jQuery已经不再支持IE8及以下版本的IE浏览器,所以才出现了这个问题。

jQuery 2.0将移除对IE6/IE7/IE8的支持
http://www.weste.net/2012/7-24/84174.html

解决方法很简单,在网页头部插入这样的代码,让IE8及以下版本浏览器引用jQuery 1.9的CDN就行了。

  1. <!--IE8只能支持jQuery1.9-->
  2. <!--[if lte IE 8]>
  3. <script src="http://cdn.bootcss.com/jquery/1.9.0/jquery.min.js"></script>
  4. <![endif]-->
来自为知笔记(Wiz)

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

0

暂无评论

评论前:需填写以下信息,或 登录

用户登录

忘记密码?